Jump to content


Photo

Led Bank Simulator And 12f683


3 replies to this topic

#1 fraser

fraser

    Newbrie

  • Members
  • 3 posts

Posted 19 April 2010 - 12:16 PM

Hi,

Trying to look at the outputs from a 12F683 using the LED bank, put there is no GPIO option in pull down menu. I have tried typing GPIO in the box and saving but again nothing happens to the LEDs when the simulation runs.

Am I doing something silly?

Fraser

#2 Dave

Dave

    Super Maniac

  • Administrators
  • PipPipPipPipPip
  • 2,091 posts
  • Gender:Male
  • Location:UK
  • Interests:How things work, Electronics, Software, Cycling.

Posted 19 April 2010 - 05:59 PM

fraser,

Trying to look at the outputs from a 12F683 using the LED bank, put there is no GPIO option in pull down menu. I have tried typing GPIO in the box and saving but again nothing happens to the LEDs when the simulation runs.

GPIO is not fully supported in the simulator, best way to do this is to use a similar PIC16 target for testing with the simulator.

Regards
Dave

#3 fraser

fraser

    Newbrie

  • Members
  • 3 posts

Posted 19 April 2010 - 06:36 PM

Dave,

Ok thanks. I thought there may have been a way using ALIASES to do this.

Fraser

#4 TomF

TomF

    Enthusiast

  • EstablishedMember
  • PipPip
  • 112 posts

Posted 09 November 2010 - 10:31 AM

I use 12F devices more than any other and was really hoping simulation would be avaliable in V7 for the 12F683

Although, the 16F devices are now so cheap, im thinking of moving up..



Reply to this topic



  


1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users