Jump to content

zzjoki

EstablishedMember
  • Content count

    42
  • Joined

  • Last visited

Community Reputation

0 Neutral

About zzjoki

  • Rank
    Regular
  1. Suggestion For The Ide

    Thanks for the ideas. I wanted to get this going and lost interest. Is the voltage parameter in error? You specified 3.25 volts for a 5 volt part - I think.
  2. Hi Jimeer and all: I had a key for the IDE and compiler. Anyway, does it work for you now? jk
  3. Hi Jimeer, I did not see if you tried the DEP setting. Also, you can search this forum (where I found mention of these issues) for more information. DEP options are found under Control Panel / System and Security / System / Advanced System Settings / Performance - Settings / Date Execution Prevention / toggle on the "Turn On DEP for all programs and services except those I select" setting . Sourceboost installer places a bunch of it's programs in the exception list including preg.exe. On my machine it benches Window's "happy index" higher with DEP set as above. jk
  4. Hi, I read about the DEP settings and registration. On my machine DEP was turned off except for essential programs. I turned it on for all programs, then a bunch of Sourceboost programs appeared in the box. I rebooted, repeated the preg.exe steps, tested the IDE and it worked. Turned off the DEP rebooted and the IDE, extra plugins, compiler appear to work now. (Perhaps our "buddy" preg.exe would know more if it could talk. I'd like to squeeze a confession out of it.) jk
  5. Hi, I am trying to install SB 7.2 on a W7 Pro machine for the first time on this machine. I have done pretty much did what I did with my laptop (which works fine). Invoked preg.exe from Program Files (x86), filled in my name and key as supplied by Pavel or Dave. Get indication of "success" in the command line windows. I start up the IDE, compile the interupt.c file and the output indicates that SB C is UNREGISTERED. Uninstalls, reinstalls, reboots change nothing. AFAIK I am operating with an owner account that has admin privledge. Same stuff happens with the plugins. They (extras) appear to register in preg.exe, but they don't load in the IDE. John
  6. How do you set up a firewall (specifically Comodo) for multithreaded compilation? I am refering to the installation message about port 5584 and 2+ threads. I found the network policy tab in Comodo and have boostbuild_server.exe set as "trusted application" which means that it doesn't stop much of anything. However, when I compile with 1,2, or 4 threads (this is an old Intel E2160 dual core with XP), I don't see much difference. I don't see error messages either. How do I know it is working? What differences should I see, typically. John
  7. WDT is on, could be messing things up.
  8. Thanks for the reply. I will keep experimenting and forward the file if it happens again. It could have been something I did, especially since I'm just playing around at this point.
  9. Hi, OK. I'm playing around with 7.05 and today I attempt to open the ledblock project under the novo foler. I think I was messing with this project yesterday. Now the project starts up empty, and I am unable to add files to it. Something is weird. I copied the old project file (from 6.97) over the corrupted (?) project file and now the project seems fine. I guess it would be nice to have explicit control over where and when a project is saved. Maybe the feature is there now, but it is not obvious. I guess SB IDE does a save when you close or open new projects, but what if I want to save it under another name and confirm that it was indeed written and flushed etc. I guess I can rename it with a windows utility...but still jk
  10. Novo Led Blink

    Hi Dave, Yes, that (-swcs) fixed it. I just open up the package and started playing around. Didn't read or check anything. Thanks for the help. jk
  11. Novo Led Blink

    I'm playing with 7.05 and Novo. I tried NovoLedFlash.c as a stand alone project. Tried using the LED plugin. Not seeing anything blink. Everything is pretty much default. (Since the RTOS is controlling program flow, would the code flow jump around in the simulator? Am I suppose to be able to trace into library function though I don't have source code?) jk
  12. Pickit 2

    It been a while but I've used a Pickit 2 and it works very well. I think most folks prefer the 2 or 3 over the ICD2 or ICD3 for hobby type work, at least. I use a boot loader and RS232/USB cable, but I believe there is a program included with the Pickit 2/3 which can be called up from SB for loading. Maybe someone who knows more would comment or correct this if wrong. jk
  13. As a possible awkward workaround .... What if you evaluate the expression in C, assign it to a variable, then load the variable in assembler?
  14. Isn't the number of breakpoints determined by resources on the target chip? Anyway, for hobby programming and debugging I still like emulation + serial port + bootloader (maybe I don't know any better).
  15. Sourceboost Ide Installation

    Although SB runs fine on my Vista Home Premium SP1 laptop, this reminds me of a problem with Corel Wordperfect x4, where you had to download a MFC lib file for VC 2005 before WP Lightning worked. This is a guess, but my interpretation is that the developer systems assumed the target environment will contain support libraries which are no longer present in Vista (or maybe they need to be updated)?
×