Jump to content
Sign in to follow this  
peterae

Beta Version Expired

Recommended Posts

peterae,

Hi

Errm what happens when the version expires, can we not use the beta until a full version is released for sale. :D

A new beta release or a full release will be available before the beta version expires.

 

Regards

Dave

Share this post


Link to post
Share on other sites

Hi Dave

Not sure if it said 1.5.07 or 5.1.07

but it would appear it thinks i am trying to fool it not to expire even tho it hadnt.

When i switched my computer on today it said the 27th January, which is strange because i dont remeber altering it.

 

When i built it makes the windows error noise, and then seems to stop responding,i thought it was crashing but if you leave it for a while a message comes up

 

Your system clock appears to have been set back, possibly in an attempt to defeat the security system on this program. Please correct your system clock before trying to run this program again. If your clock is correct, please contact the author of this program for instructions on correcting this error (report code CCB-F).

 

Even tho i have set the correct date i get this.

Share this post


Link to post
Share on other sites
Hi Dave

Not sure if it said 1.5.07 or 5.1.07

It should be V6.xx.
but it would appear it thinks i am trying to fool it not to expire even tho it hadnt.

When i switched my computer on today it said the 27th January, which is strange because i dont remeber altering it.

 

When i built it makes the windows error noise, and then seems to stop responding,i thought it was crashing but if you leave it for a while a message comes up

 

Your system clock appears to have been set back, possibly in an attempt to defeat the security system on this program. Please correct your system clock before trying to run this program again. If your clock is correct, please contact the author of this program for instructions on correcting this error (report code CCB-F).

 

Even tho i have set the correct date i get this.

The security system is rather clever, it detects interefence with the clock if the version is time limited.

The expirey on the current release (V6.60) is May 2007.

 

Which version are you using ?

Make sure you have the BoostBasic toolsuite selected, if its set to the wrong one you may get an error - Menu Settings->Toolsuite.

 

Regards

Dave

Share this post


Link to post
Share on other sites

Hi Dave

Version is 6.60

Basic is selected.

 

OK the expirary is May 07 it seems strange that it has locked me out then.

 

I have 2 installations of this 1 at home, and 1 at work, so i can work on my project in both places and transport the source from 1 to the other.

Something strange happened at home last night as well, i found that what ever basic source i was compiling, the asm and lst file would not represent it, it always showed my main project in the lst and asm file even tho if i loaded a file called test that had a few lines of code in, and i then built it the lst and asm file would have the correct test prefix but still have the assembled code of the previous project, didnt matter what i did, the only way i could solve this was to delete the boost basic folder entirley and then drop a backed up folder that was created before the problem in place of it.

 

Anyway i am still trying to get my work 1 up and running, the home 1 is now ok.

 

I tried to delete the folder at work, to start a fresh installation but it would not delete.

 

these are problems i found so far.

 

 

 

sub main()

Dim ErrorPos as Integer

Dim DeadBand as Integer

Dim Sum as Integer

' this works

Sum = ErrorPos + DeadBand ' this works

If Sum < 0 then

Goto notnearpos

End if

goto indeadband

' this doesnt

If ( ErrorPos + DeadBand ) < 0 then ' this doesnt work

goto notnearpos

End if

 

notnearpos:

 

indeadband:

end sub

 

 

**********

also this doesnt fail gracefully

 

Dim Buffer(10) as byte

sub main()

 

call BufAdd()

 

end sub

 

sub BufAdd()

Buffer = "" ' a mistake didnt mean this to be hear

Buffer(0) = 0

End sub

 

I know theres a deliberate mistake but boost basic gives an access violation.which gives no clue as to where the problem is or what it is.

 

*************

When defining an interrupt sub

this works

 

sub interrupt()

Dim aa as byte

aa = aa + 1

end sub

 

This doesnt work but it doesnt report any errors you just dont get any code appear in the asm

 

sub Interrupt() 'note the capital I

Dim aa as byte

aa = aa + 1

end sub

******************************

I have found solutions with the problems above ,but i thought i would let you know, incase you were not awear of these.

 

Happy New Year

Peter

Share this post


Link to post
Share on other sites

peterae,

 

This topic contains too much which makes it hard to reply sensibly.

Don't be afraid to start a new topic.

 

If you have found bugs please report them in the bugs forum.

 

Regards

Dave

Share this post


Link to post
Share on other sites

Hi Dave

ok noted about bugs forum

 

I am still unable to use the IDE to build the project, the answer to your post #4

is version 6.60

and yes i have selected Basic from the toolsuite.

 

surely it would only look for date tampering when it has exired not before, so is this a bug or something ive done, and how can i get it compiling again.

 

Thanks

Peter

Share this post


Link to post
Share on other sites

peterae,

Hi Dave

ok noted about bugs forum

 

I am still unable to use the IDE to build the project, the answer to your post #4

is version 6.60

and yes i have selected Basic from the toolsuite.

 

surely it would only look for date tampering when it has exired not before, so is this a bug or something ive done, and how can i get it compiling again.

 

Thanks

Peter

Please mail the compiler build text to support@sourceboost.com to get a fix.

 

Regards

Dave

Share this post


Link to post
Share on other sites

peterae,

How do i obtain the compiler build text.

 

Peter

Press the build button ('B' on the tool bar).

After the build is complete copy and paste the text in the build output window into an email.

 

Regards

Dave

Share this post


Link to post
Share on other sites

Hi Dave

 

It doesnt build, it comes up with an error as follows

 

Your system clock appears to have been set back, possibly in an attempt to defeat the security system on this program. Please correct your system clock before trying to run this program again. If your clock is correct, please contact the author of this program for instructions on correcting this error (report code 0,2940,2926).

 

the build window contains no code other than this

 

Building...

Removing Target: _obj

Failed to Locate output file '_.obj'

Done

 

is it the report code 0,2940,2926 you want me to email.

Share this post


Link to post
Share on other sites

Peter,

 

Send what you have.

 

Regards

Dave

Share this post


Link to post
Share on other sites

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...