Jump to content
Sign in to follow this  
Benj

Error -1073741819

Recommended Posts

Hello

 

first i get this windows

 

File name: C:\Documents and Settings\Ben\Desktop\ERROR\Flowcode1.c

Generated by: Flowcode v3.1.0.31

Date: Saturday, March 10, 2007 16:07:56

Licence: Professional

Registered to: Ben Rowland

 

http://www.matrixmultimedia.com

 

Launching the compiler...

 

BoostC Optimizing C Compiler Version 6.52 (for PIC18 architecture)

http://www.sourceboost.com

Copyright© 2004-2006 Pavel Baranov

Copyright© 2004-2006 David Hobday

 

Licensed to FlowCode User under Single user Pro License for 1 node(s)

Limitations: PIC18 max code size:Unlimited, max RAM banks:Unlimited

 

Flowcode1.c

Starting preprocessor: "C:\Program Files\Matrix Multimedia\Flowcode V3\BoostC\pp.exe" "C:\Documents and Settings\ALAN\Desktop\ERROR\Flowcode1.c" -i "C:\Program Files\Matrix Multimedia\Flowcode V3\BoostC\include" -d _PIC18F452 -la -c2 -o Flowcode1.pp -v -d _BOOSTC -d _PIC18

 

Flowcode1.c success

 

success

 

...

Return code = 0

 

Launching the linker/assembler...

 

Return code = -1073741819

 

FINISHED

 

And than pops out a window saying

 

Error: Access at 0x7C91084b ( tried write to 0x00030FFC), program terminated

 

Has any one had anything similar to this problem as a few of our users are reporting it. Any help would be appreciated.

Share this post


Link to post
Share on other sites

Benj,

 

Any help would be appreciated.

Sounds like a linker crash, could be cause by bad output from the BoostC compiler. Please provide a BoostC project with the C source code in it that causes the problem, then we can investigate.

Send to support@sourceboost.com.

 

Regards

Dave

Share this post


Link to post
Share on other sites

Hello Dave

 

I think I have found a workaround for the problem. It seems to be occuring only with computers that are running Windows XP Service Pack 2 and that are equipped with multiple processors that support processor power management features.

 

There is a hot fix available from:

 

http://support.microsoft.com/?id=896256

 

Regards Ben

Share this post


Link to post
Share on other sites

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...