Jump to content
Sign in to follow this  
sludge

General Error

Recommended Posts

Hi.

 

After some time away from home doing other stuff, I've tried to recommence OO programming of my PICs.

 

Before I left I had managed to compile the example project OS,  for the default target. I tried a few other targets but started to have problems - which I thought might be to do with choice of target.

 

I've just downloaded and run 5.0.5 and gone back to the original target 16F84. Now even it won't work. I just get

a whole bunch of 'General error' messages - starting with 3 of them at line 29.

 

I've obviously changed something but I don't know what.

 

Can you help?

 

Regards,

 

SLJ

Share this post


Link to post
Share on other sites

Hi and sorry for wasting anybody's time.

 

I'd altered the original source by moving class definitions around. I'd got the OS class before the Task class and of course the OS has the Task as one of it's args.

 

Regards,

 

Dumb and Dumber

Share this post


Link to post
Share on other sites

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...