Jump to content
Sign in to follow this  
Picxie

Variable Masking Not Working

Recommended Posts

Source boost 6.85 BoostCPic16 and BoostCpic 18

Seems to have crept in since 6.5

 

Variable masking has stopped working

 

In the following example I have a struct called data, a function has a parameter called data. The compiler is trying to use the struct called data in the function.

 

#include <system.h>
#include "TestVarMask.h"

#define BUFFER_SIZE 10
struct buffer
{
char Buffer[BUFFER_SIZE];
}serial, data;

void storeAtWithNameConflict(char index, char data)
{
serial.Buffer[index] = data;
}

void storeAtWithoutNameConflict(char index, char storeData)
{
serial.Buffer[index] = storeData;
}

void main()
{
storeAtWithNameConflict(3, 'a');
storeAtWithoutNameConflict(5, 'a');
}

Share this post


Link to post
Share on other sites

Fixed. Fix will be available in the coming release. Thanks for reporting.

 

Regards,

Pavel

Share this post


Link to post
Share on other sites

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...