Jump to content
Sign in to follow this  
chuckj

How Do I Specify Include Dirs That Have A Space In The Dir Name?

Recommended Posts

I have started using NOVO RTOS and would like to keep the NOVO .h files in c:\Program Files\SourceBoost\include directory.

So in SourceBoost IDE Extra compiler options I put:

 

-I\Program Files\SourceBoost\include

 

Because of the space in "Program Files", this makes the compiler think there is an extra file "Files\SourceBoost\include" to compile.

So I try to put Program Files in double quotes like this:

 

-I\"Program Files"\SourceBoost\include

 

This works OK IF I use the COMPILE option.

If I use the BUILD option, I get a usage error on pp which spits out all of the pp command line options.

 

Of course I can move the NOVO .h files to my build directory or always use the COMPILE option, but I am wondering if anyone has a solution for accessing include dirs that have a space in the name.

 

Using BoostC ver 6.95.

 

Thanks!

Share this post


Link to post
Share on other sites

Thanks for the reply, I have already tried that.

Putting double quotes around the entire path results in a similar error as in my first case:

 

Unable to open input file: C:\Program Files\SourceBoost\include.

 

My Extra compiler options line actually looks like:

 

-O2 -I ..\..\modbus\rtu;..\..\modbus\include;port;"C:\Program Files\SourceBoost\include"

 

It was working fine before I added the last path.

Share this post


Link to post
Share on other sites
Thanks for the reply, I have already tried that.

Putting double quotes around the entire path results in a similar error as in my first case:

 

Unable to open input file: C:\Program Files\SourceBoost\include.

 

My Extra compiler options line actually looks like:

 

-O2 -I ..\..\modbus\rtu;..\..\modbus\include;port;"C:\Program Files\SourceBoost\include"

 

It was working fine before I added the last path.

 

Than something else in yur setup must be wrong. Including path with spaces into double quotes is the way how windows works. I also tried your options and could not reproduce the problem. They work just fine:

 

"C:\Program Files\SourceBoost\boostc.pic16.exe" -t PIC16F648A -O2 -I ..\..\modbus\rtu;..\..\modbus\include;port;"C:\Program Files\SourceBoost\include"  test.c "..\My Documents\Test\timer.c"

BoostC Optimizing C Compiler Version 6.95 (for PIC16 architecture)
http://www.sourceboost.com
Copyright(C) 2004-2009 Pavel Baranov
Copyright(C) 2004-2009 David Hobday

Licensed to Pavel Baranov under Single user Pro License for 1 node(s)
Limitations: PIC12,PIC16 max code size:Unlimited, max RAM banks:Unlimited


test.c
..\My Documents\Test\timer.c

success
Done

 

Regards,

Pavel

Share this post


Link to post
Share on other sites

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...