Jump to content
Sign in to follow this  
teunizz

Build (F7) does not work after upgrading

Recommended Posts

After upgrading from 5.5 to 5.2.2 the Build button doesn't function anymore. When i use it (or press F7) the outputscreen blanks and nothing happens. The other buttons work normal like Compile, Assemble and Programmer. I checked  Settings -> Build -> Build options...  Any idea?

 

Grtz, teunizz

Share this post


Link to post
Share on other sites
Guest Pavel

I can not reproduce this. Build works fine on my machine.

 

Is the output panel absolutly blank after you press the build button (or F7) or it still prints anything?

 

Regards,

Pavel

Share this post


Link to post
Share on other sites
After upgrading from 5.5 to 5.2.2 the Build button doesn't function anymore. When i use it (or press F7) the outputscreen blanks and nothing happens. The other buttons work normal like Compile, Assemble and Programmer. I checked  Settings -> Build -> Build options...  Any idea?

 

Grtz, teunizz

This has happened for me too, but only couple times. Restarting the IDE has always helpped. Build doesn't "build" if you haven't made any changes to the sources.

Share this post


Link to post
Share on other sites
Guest Pavel

Since now ide uses make to build th project the "build" command will do anything only if sources were changed. For example if you change a C file from a project the build command will call compiler and assembler (this assumes that both compiler and assembler are enabled in the Build options dialog). If something in assembly file was changed than the build command will start assembler only. If nothing was changed the build command will do nothing. Let me know if that's not what you are seeing.

 

Regards,

Pavel

Share this post


Link to post
Share on other sites
Guest peter

On my system Build (F7) only works if in Build options "program" is not marked!

Program itself works ok. but if is take it in the build options. Build doesn't work anymore

Share this post


Link to post
Share on other sites
Guest Pavel

I found the cause of this problem. It will be fix in the next release. The workaround is to disable programming as part of the build process (in the "Build options" dialog).

 

Regards,

Pavel

Share this post


Link to post
Share on other sites

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...