Jump to content

Recommended Posts

Hello,

 

I have a new computer and I try to compile the project I am working on (in MPLAB ide). Compilation was OK, but during the next step it was not successful, and I have the following info in the build windows :

 

success

Executing: "E:\Program Files\SourceBoost\boostlink_pic.exe" "C:\Polarimetre\MPLAB Polarimetre\PousseSeringue.obj" "C:\Polarimetre\MPLAB Polarimetre\RS232.obj" "C:\Polarimetre\MPLAB Polarimetre\Affichage.obj" "E:\Program Files\SourceBoost\Lib\libc.pic18.lib" "E:\Program Files\SourceBoost\Lib\eeprom.pic18.lib" -O1 -p "PousseSeringue" -t 18F4520

BoostLink Optimizing Linker Version 6.97

http://www.sourceboost.com

Copyright© 2004-2009 Pavel Baranov

Copyright© 2004-2009 David Hobday

 

 

Optimisation level:1

Bytes:0x00 0x00 0x04 0x07 0x00 0x1A 0x00 0x00 0x00 0x31 0x00 0x45 0x3A 0x5C 0x50 0x72 0x6F 0x67 0x72 0x61 0x6D 0x20 0x46 0x69 0x6C 0x65 0x73 0x5C 0x53 0x6F 0x75 0x72

.obj file error:Expected FILE_SECTION

 

failure

BUILD SUCCEEDED: Mon Feb 08 15:19:35 2010

And a windows tell me "failed to load PousseSeringue.cof".

 

I found a message on this forum but it is quit old and had no relation with my situation (http://forum.sourceboost.com/index.php?s=&...post&p=7638) : I have no information in the "project:Directories).

 

I perform compîlation in the sourceboost IDE, it works fine !

 

NB : I have installed the last version of MPLAB and Sourceboost.

 

Thanks for your help,

Jean-Marie

Link to post
Share on other sites

schneiderj,

Bytes:0x00 0x00 0x04 0x07 0x00 0x1A 0x00 0x00 0x00 0x31 0x00 0x45 0x3A 0x5C 0x50 0x72 0x6F 0x67 0x72 0x61 0x6D 0x20 0x46 0x69 0x6C 0x65 0x73 0x5C 0x53 0x6F 0x75 0x72

.obj file error:Expected FILE_SECTION

Which version of MPLAB are you using?

 

This is an internal error, so you should never get to see it. The only thing I can think of is the the order of linkage is different between MPLAB and SourceBoost IDE, but even so this message should never appear.

Please send all the project files to support@sourceboost.com so we can take a look.

 

Regards

Dave

Link to post
Share on other sites
schneiderj,
Bytes:0x00 0x00 0x04 0x07 0x00 0x1A 0x00 0x00 0x00 0x31 0x00 0x45 0x3A 0x5C 0x50 0x72 0x6F 0x67 0x72 0x61 0x6D 0x20 0x46 0x69 0x6C 0x65 0x73 0x5C 0x53 0x6F 0x75 0x72

.obj file error:Expected FILE_SECTION

Which version of MPLAB are you using?

 

This is an internal error, so you should never get to see it. The only thing I can think of is the the order of linkage is different between MPLAB and SourceBoost IDE, but even so this message should never appear.

Please send all the project files to support@sourceboost.com so we can take a look.

 

Regards

Dave

Dave thanks you for your answer. I send you the project.

MPLAB version is 8.43.00.00

 

Jean-Marie

Link to post
Share on other sites

Jean-Marie,

 

Dave thanks you for your answer. I send you the project.

MPLAB version is 8.43.00.00

In your MPLAB project file Affichage.c is never rebuilt, just linked in as an .obj file as the Affichage.c file is not in the MPLAB project but Affichage.obj is. Rebuilding this file resolves the issue (for me at least), so it looks like that file make have been built with a different version of the compiler.

 

Please add Affichage.c to the project and remove Affichage.obj from the project.

 

Regards

Dave

Link to post
Share on other sites

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...