Jump to content
Sign in to follow this  
ysj

Compiler assemble error

Recommended Posts

When I compile my code, I receieve no error, but it changes my assembly code. Please look below to see where the code was changed. I mark it with ?????.

 

;;;;;;;;char RcTime(void) {

_RcTimeend

 

I can make it work by inputting the code "goto $-3", but this causes it to lose one cycle, and I don't want that to happen.

I want to get a better accurate rctime value.

 

I hope it will be fixed.

 

PicAntIDE Version  : 5.0

             compiler: c2c- plus

  compiler version : 5.0

  os system        : Window 95

Share this post


Link to post
Share on other sites

When I compile my code, I receieve no error, but it changes my assembly code. Please look below to see where the code was changed. I mark it with ??????.

 

;;;;;;;;char RcTime(void) {

_RcTimeend

 

I can make it work by inputting the code "goto $-3", but this causes it to lose one cycle, and I don't want that to happen.

I want to get a better accurate rctime value.

 

I hope it will be fixed.

 

 

PicAntIDE Version  : 5.0

            compiler: c2c- plus

 compiler version : 5.0

 os system        : Window 95

Share this post


Link to post
Share on other sites
Guest Pavel

I don't see any code in your report (other than the beginning of the RcTime function). Was your report text posted correctly?

 

Regards,

Pavel

Share this post


Link to post
Share on other sites

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...