Jump to content
BazookaJo

Beginners Pic18f Problem - Chip Writes Ok But Does Not Work...

Recommended Posts

Hi guys - pretty empty Subforum so hope someone reads this..... :rolleyes:

 

I have some PCBs that I had made some years ago which I tend to have built in very short runs i.e. around 7-8 at a time.

 

So - I have my hobbyist Microchip PIC programmer, and my code.

 

I select my hex and the code writes to the chip without any real issues, though I do get an error which suggests the hex file is actually larger than the chip's capacity even though the back-end is zero'd.

 

Other than that - the programming seems to work fine except it doesn't work in the machine :(

 

For reasons I will not go into, my chip guy has not left a forwarding address, and I'm left scratching around in the dark.

 

Now assuming the code I was given back in the day is all present and correct (which may yet prove not to be the case) can anyone suggest any reason it might not be working i.e. obvious options/silly mistakes that a rookie like me could make?

 

A very big thanks in advance to anyone that can throw a few crumbs of knowledge my way.

 

Very best regards

 

Joe.

Share this post


Link to post
Share on other sites

Your content will need to be approved by a moderator

Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×