Jump to content
Sign in to follow this  
ChrisR

Failed To Locate Output File..

Recommended Posts

I've just upgraded from Souceboost C 6.? to 7.01.

 

I now can't get any of the Sourceboost tools to work. They were working OK under 6.?.

 

A compile produces the output:

"C:\Program Files\SourceBoost\boostc_pic16.exe" -t PIC16F690 -idx 1 -obj Release -d _RELEASE test.c

 

Failed to locate output file 'Release\test.obj'

Done

 

Failed

 

 

A build produces:

Building...

Failed to locate output file 'Release\test.hex'

Done

 

Failed

 

 

The source, test.c is merely:

void main()

{

unsigned char n;

n=0;

 

}

Share this post


Link to post
Share on other sites
I've just upgraded from Souceboost C 6.? to 7.01.

 

I now can't get any of the Sourceboost tools to work. They were working OK under 6.?.

 

A compile produces the output:

"C:\Program Files\SourceBoost\boostc_pic16.exe" -t PIC16F690 -idx 1 -obj Release -d _RELEASE test.c

 

Failed to locate output file 'Release\test.obj'

Done

 

Failed

Is that the complete compile window output, as I would expect to see more output?

It might be that your antivirus software is preventing boostc_pic16.exe from executing.

 

Regards

Dave

Share this post


Link to post
Share on other sites

Excellent! Yes, you are right.

 

Disabling AV and firewall is one of the things I usually try when something doesn't work, but it never crossed my mind it would stop a compiler or linker working.

 

I use Commodo firewall and it was its sandbox feature causing it. Pspawn.exe, I think. Made that trusted and it works fine with the AV/firewall turned back on.

 

Also, it's worth noting that once all the output files in the Release directory existed, the compile and/or build process would carry on working even without the fix, as above.

Share this post


Link to post
Share on other sites

Hi Chris,

 

I've exactly the same problem. After upgrading to V7.01 from V6.97, the compiler can't compile to OBJ. Did you manage to solve the problem ?

 

Rgds

Glennon

 

I've just upgraded from Souceboost C 6.? to 7.01.

 

I now can't get any of the Sourceboost tools to work. They were working OK under 6.?.

 

A compile produces the output:

"C:\Program Files\SourceBoost\boostc_pic16.exe" -t PIC16F690 -idx 1 -obj Release -d _RELEASE test.c

 

Failed to locate output file 'Release\test.obj'

Done

 

Failed

 

 

A build produces:

Building...

Failed to locate output file 'Release\test.hex'

Done

 

Failed

 

 

The source, test.c is merely:

void main()

{

unsigned char n;

n=0;

 

}

Share this post


Link to post
Share on other sites
Guest Tengo el mismo Problema

mi problema es el mismo y desabilitado el mi antivirus y aun así obj no se ejecuta

My problem is the same and disabled my antivirus and still obj does not run

Share this post


Link to post
Share on other sites

Your content will need to be approved by a moderator

Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×