Jump to content
Sign in to follow this  
tsmith35

Plugin '7 Segment Led' Has Incompatible Api Version (2.00) And Was Not Loaded

Recommended Posts

Just upgraded to v7.01 w/ the 7.01 IDE plugins. I keep getting this message at IDE startup: Plugin '7 Segment LED' has incompatible API version (2.00) and was not loaded

 

Any ideas?

 

Edit: this morning, it also started reporting this: Plugin 'Button' misses version interface.

Edited by tsmith35

Share this post


Link to post
Share on other sites
Just upgraded to v7.01 w/ the 7.01 IDE plugins. I keep getting this message at IDE startup: Plugin '7 Segment LED' has incompatible API version (2.00) and was not loaded

 

Any ideas?

 

Edit: this morning, it also started reporting this: Plugin 'Button' misses version interface.

 

API between IDE and plugins changed in version 7 (to support multiple plugin instances). It sounds that you try use IDE v7 with plugins v6. Solution: upgrade plugins to maths IDE version (if you run IDE v7 you need plugins v7)

 

Regards,

Pavel

Share this post


Link to post
Share on other sites
API between IDE and plugins changed in version 7 (to support multiple plugin instances). It sounds that you try use IDE v7 with plugins v6. Solution: upgrade plugins to maths IDE version (if you run IDE v7 you need plugins v7)

 

Pavel, thanks for the reply. I downloaded the v7.01 plugins from: http://www.sourceboost.com/CommonDownload/...ins/plugins.exe

 

Does the new version of 7segmentLEDs have a different name? Perhaps the old version has a different name and is not overwritten upon installation of the v7.01 plugins. I deleted the files 7segmentLEDs.dll and 7segmentLEDs.html and tried reinstallation of the v7.01 plugins, but no new files of the same name were created.

Share this post


Link to post
Share on other sites
API between IDE and plugins changed in version 7 (to support multiple plugin instances). It sounds that you try use IDE v7 with plugins v6. Solution: upgrade plugins to maths IDE version (if you run IDE v7 you need plugins v7)

 

Pavel, thanks for the reply. I downloaded the v7.01 plugins from: http://www.sourceboost.com/CommonDownload/...ins/plugins.exe

 

Does the new version of 7segmentLEDs have a different name? Perhaps the old version has a different name and is not overwritten upon installation of the v7.01 plugins. I deleted the files 7segmentLEDs.dll and 7segmentLEDs.html and tried reinstallation of the v7.01 plugins, but no new files of the same name were created.

 

7segmentLEDs came from a third party author. It's the author responsibility to update plugin sources and produce a new executable that will compatible interface with IDE v7.

 

Regards,

Pavel

Share this post


Link to post
Share on other sites
7segmentLEDs came from a third party author. It's the author responsibility to update plugin sources and produce a new executable that will compatible interface with IDE v7.

 

Ah, that explains it! I thought it was part of the Plugins pack. Thanks!

Share this post


Link to post
Share on other sites
API between IDE and plugins changed in version 7 (to support multiple plugin instances). It sounds that you try use IDE v7 with plugins v6. Solution: upgrade plugins to maths IDE version (if you run IDE v7 you need plugins v7)

 

Pavel, thanks for the reply. I downloaded the v7.01 plugins from: http://www.sourceboost.com/CommonDownload/...ins/plugins.exe

 

Does the new version of 7segmentLEDs have a different name? Perhaps the old version has a different name and is not overwritten upon installation of the v7.01 plugins. I deleted the files 7segmentLEDs.dll and 7segmentLEDs.html and tried reinstallation of the v7.01 plugins, but no new files of the same name were created.

 

7segmentLEDs came from a third party author. It's the author responsibility to update plugin sources and produce a new executable that will compatible interface with IDE v7.

 

Regards,

Pavel

 

SO how do we contact this developer

Share this post


Link to post
Share on other sites

7segmentLEDs came from a third party author. It's the author responsibility to update plugin sources and produce a new executable that will compatible interface with IDE v7.

 

Understood... but assuming you haven't been able to contact Richard to update it, have you or Dave got the sourcecode for this plugin, so that you (or I) could recompile it for v7?

 

I've just updated to v7.05 and licensed the v7 plugins, and it was a real disappointment to realize that the 7-segment LED is now gone.

 

Thanks.

Share this post


Link to post
Share on other sites

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...