Jump to content
tom 2007

Autocompletion + Prototype Hits Problems

Recommended Posts

Hi

 

I'm having some problems with the IDE V7.01 and autocompletion/prototype hits.

 

When i type a function name and "(" the tooltip text is not always displayed it only seems to work with some system functions like delay_ms() etc.

When i press CTRL+Space for the autocompletion window it only shows when i already typed the entire function name and the size of is is very small so it's not possible to read the text in.

 

Anyone else with these problems?

 

Tom

Share this post


Link to post
Share on other sites

Hi Tom,

 

Tooltip display seems to require knowledge of the function prototype. I put my prototypes into my module header files and add the header files to the project window. The IDE seems to scan the header file and extract the prototypes.

 

The tooltip only highlights the first two parameters on the argument list. I brought this up some time ago but it never got fixed.

 

The autocompletion seems only to recognise compiler keywords and not everything that is in the browser window.

 

There are still some broken bits to be sorted out yet.

 

Cheers

 

Reynard

Share this post


Link to post
Share on other sites

Your content will need to be approved by a moderator

Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×