Jump to content
Sign in to follow this  
Lecalou60

Problem Was Compiling My Pic 16F84A

Recommended Posts

Hello,

I'm new to the forum. I use Flowcode V5.2 and am having a trouble to compile my little program. A generation of C file, everything goes well. As soon as I want my generated assembly file, I receive an error message:

D1> error: Failure

Can you help me?

Thank you in advance for your help.

Lecalou60

post-6712-0-77778400-1343675973_thumb.png

Détection infra rouge.c

Share this post


Link to post
Share on other sites

Lecalou60,

Hello,

I'm new to the forum. I use Flowcode V5.2 and am having a trouble to compile my little program. A generation of C file, everything goes well. As soon as I want my generated assembly file, I receive an error message:

D1> error: Failure

Can you help me?

Looks like the preprocessor may be terminating with an error. The preprocessor works on the code before the compiler in response to preprocessor directives such as #ifdef, #endif, #define.

 

To find the cause I would do the following:

1) Take a copy of the project.

2) Keep removing chunks of the code until the preprocessor is successful,

3) Slowerly add code back in again until the error occurs again.

Then you will hopefully know what is causing a problem with the preprocessor and then be able to avoid or correct it.

 

I hope that helps

Regards

Dave

Share this post


Link to post
Share on other sites

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...