Jump to content
Sign in to follow this  
L de vries

Mplabx Plugin Points To Old Linker Name?

Recommended Posts

Hello,

I have a problem,

1: I uninstalled sourceboost V7.10, in the ad/remove software pannel (windows)

2: removed programfiles (x86)\ sourceboost folder

3: uninstalled Sourceboost plugin in MPlabX

4: closed MPlabx

5: Installed sourceboost V7.11

6: started MPlab (administrator mode), installed new sourceboost plugin

7: restarted MPlab, added Toolchain.

Then i tried to clean and rebuild a project, that worked when I used sourceboost V7.10

Compiling with V7.11 was ok...

Linking was NOT, I get the popup screen mentioning that linker name is changed to new name, and that I still use the old name.....

I know how to fix this im MPlab8, but not how to fix this in MPlabX,

What must I do to let MPlabX know, what linker name it must use (or is this handeled by the plugin, and do I need an other plugin?).

Thanks in Advance,

Lieuwe

Share this post


Link to post
Share on other sites

Hi

 

happens exactly the same with MPLAB8.

The Sourceboost installer doesn't fill up the paths on the plug-in.

At the first install you have to fill in the blank paths, the upgrades inherit the configurations from previous installations, the same way it inherits the licence key.

 

Thats why the Sourceboost team provided a placeholder with the name of the old linker, just to warn us of the need to correct the paths.

 

To correct them in MPLAB X go:

Tools -> Options

in the dialog box choose the "embeded" separator

Select the Sourceboost toolchain and correct the paths as needed.

 

 

Best regards

Jorge

Share this post


Link to post
Share on other sites

Thanks Jorge,

 

For trying to help me but,

 

In MPlabX I see only the option to choose Xlaunch.exe.

C:\Program Files (x86)\SourceBoost\xlaunch.exe

 

I don't see how to "Select the Sourceboost toolchain and correct the paths as needed."

 

 

I do not know Where to give / chance the path names of

 

C:\Program Files (x86)\SourceBoost\boostc_pic16.exe and

C:\Program Files (x86)\SourceBoost\boostlink_picmicro.exe

 

To I get rid of this:

 

 

I know for MPlab 8 :

you have to give the path names of the executables of the compiler and the linker,

By "Project Tab > Set Language Tool Locations:"

 

 

 

And that works, I can compile and Link with V7.11 in MPLab 8, no problem.

And yes I had to correct the path name there by hand, also no problem

 

Best regards

Lieuwe

Share this post


Link to post
Share on other sites

If you want to keep using the old linker name try the updated dummy linker from http://www.sourceboost.com/CommonDownload/Fixes/dummy_linker.zip This dummy linker will display the same warning as the one included into the SourceBoost installation but it will also start the correct linker. To install download and unzip it into your SourceBoost installation directory.

 

Regards,

Pavel

Share this post


Link to post
Share on other sites

Hi

 

After installing the MPLAB - X plugin by Sourceboost instructions.

 

Start MPLAB X and go:

Tools -> Options

in the dialog box choose the "embeded" separator

Select the Sourceboost toolchain and correct the paths as needed.

 

Best regards

Jorge

Share this post


Link to post
Share on other sites

Problems solved with new workaround:

 

Thanks for the help here, Jorge, and Pavel.

 

First:

there are NO path names in MPLabX v1.60 for the linker for Sourceboost for as far as I could find.

 

You have the following options in the Options > Embeded > Build Tools Toolchain window

 

for type: Sourceboost Language Tool chain

there is a Base Directory: C:\Program Files\Sourceboost

and a C Compiler: C:\Program Files\Sourceboost\xlaunch.exe

and a Make Command: C:\Program Files\Microchip\MPLABX\gnuBins\GnuWin32\bin\make.exe (this is grayed, so you can't chance that)

 

there is no Linker pathname here (like in MPLab8.89)

 

So....

 

I tried Pavel's solution, indeed the after the compiler v7.11 was done, the "new linker name message" appears, but NO linking as promised (No .hex file generated). :unsure:

But.. it gave me an idea how to handle this, it is not a nice solution, but it worked.

 

I made a copy of the C:\Program Files (x86)\SourceBoost\boostlink_picmicro.exe file and renamed it to the old boostlink_pic.exe name,

I placed that file in the sourceboost installation folder, so now I have two the same linker files, one with the old, and one with the new name.

 

After that I can use SourceBoost IDE, and MPLab 8.89 with new boostlink_picmicro.exe linker file

While MPlabX uses the re-named boostlink_picmicro.exe copy.

 

Now everything works on my Laptop (windows 7 64bit)

Edited by L de vries

Share this post


Link to post
Share on other sites

Hi

 

Thanks Jorge,

 

For trying to help me but,

 

In MPlabX I see only the option to choose Xlaunch.exe.

C:\Program Files (x86)\SourceBoost\xlaunch.exe

 

Sorry but I didn't notice that Sourceboost had a different setup than the Microchip toolchains.

I don't use MPLAB X; only had an old test instal and, as the other toolchains show the same path setup as in MPLAB 8, I assumed it will apply to Sourceboost also.

 

Meanwhile, thank you for the other topic were you summed up your experience with the installation of MPLAB X + SB 711.

It served me in installing MPLAB X latest version with SB for testing ...... again.

I expect MPLAB X has matured up to something usable since Ver 1.0

.

Best regards

Jorge

Edited by JorgeF

Share this post


Link to post
Share on other sites

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...