Jump to content
Sign in to follow this  
ajbeavan

Mplabx Cant Find Libc.pic16

Recommended Posts

Hello

I am struggling to get MPLABX v1.80 to compile and link my code, I get the following messages

Error: Failed to open:../Program/

Error: Failed to open:Files/SourceBoost/Lib/libc.pic16.lib or C:\Program Files\SourceBoost\lib/Files/SourceBoost/Lib/libc.pic16.lib

 

I do not really use MPLABX I prefer the Sourceboost IDE, but I am using the Pickit3 debugger to see whats actually on the chip and get realistic timings. To get around the problem I have used the 'cof' file produced by sourceboost to build a new project in MPLABX.

 

It seems to work!!!!! I can step through the code and set breakpoints, though I cant make any sense of the timings for tmr0 and tmr1. I am using the timers to generate a PWM signal and setting them using the following code:

 

 

volatile uWORD TMR1 @ 0x000E; //combine adj reg TMR1L & TMR1H

 

#define STMR0 83

#define STMR1 536

;

;

//main program

;

;

//set starting values for timers

tmr0 = STMR0;

TMR1 = STMR1;

 

but they do not seem to be set when I step through and look at the register.

 

Any suggestions....

 

Thanks

 

adam

Share this post


Link to post
Share on other sites

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...