Jump to content

Pic18F4685 Compiles Ok But Wont Run On The Chip

Recommended Posts



I am using Matrix Multimedia's FlowCode V5 using BoostC Optimizing C Compiler Version 7.04 (for PIC18 architecture). I have tried using two chips a PIC18F2685 and a PIC 18F4685. They have 96k of program memory. I have found with the code i have written (approx 82k) that when it is compiled that the compiler has a return code of 0 showing there have been no errors. However when i run the code in the chip it will not run. I have cut about 30k of code out of my program, compiled it and it runs ok. I have then returned the code that i removed for the previous test and removed other code that was present in the previous test so i have once again reduce the code size by approx 30k. Once again the program will run ok.

Matrix multimedia has checked over my code and cannot find any issues with the code or the configuration bits. I was wondering if anyone has any ideas as to why this could be happening. Are there any issues with how the compiler handles the memory allocation with larger programs.




Link to post
Share on other sites

When the code goes over the 64k byte mark the hex file contains Extended Linear Address Records.


Does you programmer support these records or are they being ignored.


Since you can select the correct device on the programmer one would think so. Worth checking though.





Link to post
Share on other sites

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...