Jump to content

Recommended Posts

I created a workspace in Multi Project Mode

I created new project and added some c files which successfully compile.

But when I Build project I get blunt "Building... Failed" in the output window.

Thats it, no more error detailed information, nothing.

 

I even created a new project with empty files and still get the same meaning less Building... Failed.

 

Any pointer to solve this problem?

Thanks, Gaston

Share this post


Link to post
Share on other sites

Hello Gaston,

 

If you're running on Windows 7 or 8 you might want to try running SourceBoost as administrator to see if the build is successful. The OS might be restricting the application's write access so it can't create the files.

 

Worth a try -

 

Murray

Share this post


Link to post
Share on other sites

Another possibility - are you trying to use NovoRTS? I have also run across that error message while trying to use elements of that library. I have a PRO license and I have asked for the code to unlock the "goodies" file, unfortunately none of that functionality appears to work if the registration code has not been applied. I don't know if the people who look after SourceBoost have totally disappeared but I have not received any response to my request for the key that should have been provided to unlock NovoRTS as part of my PRO license. I also now see that it has been quite awhile since Dave or Pavel have posted to the SourceBoost website.

 

Can someone tell me - is this a dead product?

 

Murray

Share this post


Link to post
Share on other sites

Check also the compiler and linker path in the settings are pointing to the (x86) directory.

This one got me when I moved to Windows 8.1 from XP and re-installed.

You have to be super administrator to run the preg.exe

 

I think you are right about Dave and Pavel doing a runner.

I reported a problem to the support email address (24th November) about an FSR0 corruption when doing a compare.

So far not a cheap out of them. Found a workaround to solve it for now.

 

Cheers

 

Reynard

Share this post


Link to post
Share on other sites

As an update I wanted to let folks know that I have heard from Dave and received a registration code. It just took awhile. He says the product is definitely not dead, so that's good news.

 

I was able to recreate the OP's problem, and Reynard is right - if the compiler and linker directory is not correctly specified under Settings/Options/Tools you will only get the terse "Building... Failed" message.

 

I'm using a Windows 8.1 system and I found that SourceBoost works best if not installed in the Program Files directory (the default). I don't run across any file permissions issues when installed in C:\SourceBoost\ and I don't have to run the program as Administrator.

 

Things were much simpler in the XP days...

 

Murray

Share this post


Link to post
Share on other sites

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...