Jump to content

Recommended Posts

Tried to get answer form support but no response (in previews years answers were given within 1-3 days).


I have been using Sourceboost C for several years now together with MPLAB 8.

I am trying to make a move to MPLAB X.


I imported the project that I work on to MPLAB X and tried to compile it.

Compilation works OK

Linker fails.


In the MPLAB 8 project tree I have the file libc.pic18.lib under the LIBRARY FILES folder

I see that it is also listed in the project tree that was imported to MPLAB X

When compiling in MPLAB X I get the following error:

Failed to open:(x86)/SourceBoost7/Lib/libc.pic18.lib or C:\Program Files (x86)\SourceBoost7\lib/(x86)/SourceBoost7/Lib/libc.pic18.lib


Any idea what is the problem and what should be done?



Link to post
Share on other sites

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...