Jump to content

Recommended Posts

Hi,

I am an experienced PIC user, programmer and designer.

I am looking to move away from Wiz-C which is no longer supported. It used to be good, though frustrating because of many bugs which tended to cancel out the big productivity pluses of the product. Increasingly I had to write my own libraries and modify the product for new chips. I have now had enough and looking to change.

Anyway, I amnow  looking at these Sourceboost  products. I note that must of the forum activity was years ago. Does this mean that the user base is dying out?

Also, a number of the PICs which I use are recent 18F devices (such as those with 12bit A/Ds etc). They are not listed on the support list.

How often are new devices added to the support list? I realise of course that it would be impractical to support every PIC chip.

For instance, a newish chip I would like to use now is the 18F26K42. What are the chances of supporting that in the near future? Particularly with the IDE.

Regards,

David

Share this post


Link to post
Share on other sites

Hm, my question is not even moderated yet.

Are there plans to support the 26K62 or any of that series? They are the only 18F chips with a 12bit ADC which is why I am using them.

Also, your emulator looks promising. Any plans to support some simple elements like a potentiometer/ADC module emulation for ADC code? A terminal to interface with UART?

Regards,

David

Share this post


Link to post
Share on other sites

We do add support for the new PICs from time to time but now very often. The 18F26K42 and alike are a bit different from the existing PICS as they offset SFRs by 0x3000 and our linker does not support this yet. We looking into this but can't guarantee this will be supported (at least soon ).

 

Regards,

Pavel

Share this post


Link to post
Share on other sites
Guest albione

hi,

sorry that i am writting here but i didnt find topic for sourceboost instalation issues

I have a laptop win win10 pro x64 intel i5 8th gen, geforce mx150 ssd

when i am trying to install i getting the following error, intristingly one off my older version win 10 home i could install!

Capture.JPG

Share this post


Link to post
Share on other sites

That's an useful report. The error happens because the SourceBoost code fails to parse some text that contains non-english characters (maybe somewhere in a directory name). Does this happen on your computer?

 

Regards,

Pavel

Share this post


Link to post
Share on other sites

Hi

 

That is strange, I installed the Sourceboost IDE with Boost C and goodies licences in a new laptop (3 weeks ago) running Win 10 64bit up to date without any issues.

 

Best regards

Jorge

 

Edited by JorgeF
Trying to get ride of the pictures.

Share this post


Link to post
Share on other sites
Guest albione

well the problem is resolved i must do a fresh windows installation and were install the program without problem!

but i found out that because i have Hungarian keyboard on the laptop so when  iam trying writting a code the bracket "{" it want work if i pressing the

ctrl+alt+b its start to build the code!? so there is any possibility to change the quick key for the build?

 

thx 

Share this post


Link to post
Share on other sites

Your content will need to be approved by a moderator

Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×