Jump to content
L de vries

SB not working in MPLABX 5.10

Recommended Posts

Sb plugin did work in MPLABX v5.00 (and lower).

project did also compile.

Installed MPLABX 5.10 today, installed SB plugin as in MPLAB v5.00, installation works ok, like in MPlabX v5.00.

restart MPLABX, toolchain is added to list in tools/options/embedded tab in MPLABx 5.10.

open project is ok,

Hit clean and build project button in MPlabx, Information window opens:

Compiler toolchain "BoostC" of type "BoostC"  does not exist.Please visit Tools/Options/Embedded

to locate an installation of this toolchain or to select another compiler toolchain.

 

Project is not cleaned, and compiler does not start.

 

Embedded Build Tools tab:

Type: SourceBoost Language Toolchain

Base Directory: C:\Program Files (x86)\Sourceboost

C Compiler: C:\Program Files (x86)\SourceBoost\xlaunch.exe

Make Command: C:\Program Files (x86)\Microchip\MPLABX\v5.10\gnuBins\GnuWin32\bin\make.exe

 

Edited by L de vries

Share this post


Link to post
Share on other sites

I have the same problem, so I removed sb from mplabx then tried to reinstall, mplab now says C:\Program Files\Sourceboost  does not contain a toolchain. I restarted mplabx and i was able to add the toolchain, but when I try to build the project mplab tells me the toolchain doesn't exist.

Share this post


Link to post
Share on other sites

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...