Jump to content

And Another One...


Recommended Posts

Compile this code with SourceBoost 6.12 and run the debugger:

 

#include <system.h>

void printf(const unsigned char*);

void main(void)
{
 printf("\r\ntesttest\r\n");

 while(1);
}

void printf(const unsigned char* text)
{
 unsigned char i = 0;

 while(text[i] != 0)
 {
//  putch(text[i++]);
 }
}

The first character of the string "\r\ntesttest\r\n" is printed wrong.

(not actually printed, just look at the memorywindow and watch the fields

where SB put the string)

 

This is not a fault of the debugger, a reallife application has the same error.

 

If you the change the string in "\r\ntest\r\n" then it works fine.

 

Regards, Teuniz

Link to post
Share on other sites

I tried this patch and for now it seems ok ;)

 

Thanks for the quick response and patch.

 

Keep on the good work.

 

Regards, Teuniz

 

p.s. IDE is still reporting version 6.12 and when I start SB IDE it still

wants to download the latest patch 6.13. Altough Compiler and

linker have version 6.13...

Link to post
Share on other sites

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...