Jump to content

Auto Indent Always On In Ide


Recommended Posts

I'm using version 6.35 and when I tab over and type a line of text:

 

if(I_dont_want_auto_indent){

 

Instead of the cursor going to column 1 (like I like) it goes to column 4. This happens no matter what I have the Editor Settings dialog box "Smart Indentation" set to.

Link to post
Share on other sites

trossin,

 

I'm using version 6.35 and when I tab over and type a line of text:

 

if(I_dont_want_auto_indent){

 

Instead of the cursor going to column 1 (like I like) it goes to column 4. This happens no matter what I have the Editor Settings dialog box "Smart Indentation" set to.

Try changing tab size to 1.

 

Regards

Dave

Link to post
Share on other sites
trossin,

 

I'm using version 6.35 and when I tab over and type a line of text:

 

if(I_dont_want_auto_indent){

 

Instead of the cursor going to column 1 (like I like) it goes to column 4. This happens no matter what I have the Editor Settings dialog box "Smart Indentation" set to.

Try changing tab size to 1.

 

Regards

Dave

 

No that didn't work but I apologize for not doing a preview before submitting my post as I wanted the line indented by 4 spaces. I'll try again. Assume that bbbb is 4 spaces or 1 tab:

 

bbbbif(I_dont_want_auto_indent){

 

What I want to know is why when I turn off (leave off) "Smart Indentation" does the insert point after I hit enter show up in column 5 (under the i in if) instead of column 1. In the unix editor vi I would do a :set noai to turn this off.

 

It seems that "Smart Indentation" is always turned on. Or I do not know what it means. I checked the IDE user manual and there was no data on the subject.

Link to post
Share on other sites

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...