Jump to content

Possible Mplab Integration Problem


Recommended Posts

Hello,

 

i tried to integrate SourceBoost with MPLAB including two files i have in a folder outside the project folder because they are shared with other projects. If i doubleclick over the filename it is opened and i can edit it, but if i try to compile the project i will receive an error message that tells me that the compiler is not able to find this files.

 

Is this an integration problem or is it an MPLAB fault?

 

Thank you,

 

Wally

Link to post
Share on other sites
  • 4 weeks later...

I've discovered that unless the source is any directory except the directory with the project in, it fails to compile. I normally place the source in a source directory to avoid clutter in the root project directory and it fails to compile with Boostc. However it will work using the MPASM plugin. BoostC seems to be looking in the project directory for the file and not the subdirectory. Either MPLAB is not correctly setting the working directory for plugins apart from it's own, or there's a flag that needs to be set to tell MPLAB to do this and it's not. I did dig around in all the configuration files, and I couldn't see anything that leapt out as a missing flag in the BoostC config files.

 

HTH,

 

Andy

Link to post
Share on other sites

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...