Jump to content

Mplab - Boostc Compile Option -i Broken?


Recommended Posts

Bug description:

In the MPLAB SourceBoost "C" integration, using Compiler version 6.70 using the compiler option -i by selecting menu item Project>"Build Options...">"Project" with the "BoostC C Compiler for PIC18" tab. Selecting "Debug inline code" check box yields the option, "-di" where it should yield "-i". This option then causes all variables named "i" in the build to become null -- yielding many errors in the code.

 

Steps to reproduce:

In MPLAB (version 7.50 or 7.52) select "Project">"Build Options ...">"Project". Select the "BoostC C Compiler for PIC18" tab. Select "Debug inline code" check box yields the command line option, "-di" where it should yield "-i".

 

Expected behaviour:

I expect the option to generate the option, "-i" on the command line, not "-di".

 

The work-around is to use -i option on the "additonal Command-Line Options" line so this bug is NOT fatal.

 

Is the problem 100% reproduceable:

This is 100% reproducable.

 

IDE version: SourceBoost IDE version 6.70

Compiler: BoostC PIC18

Compiler version: Compiler version 6.70 ( for PIC18 architecture)

Target device: PIC18F2520

OS: Windows XP OS version WinXP/SP2

 

Comments:

Workaround is to use "Additional Command-Line Options" and place "-i" there.

Link to post
Share on other sites

Myself i do not see this as a bug ...

It should be documented in the install/setup instructions but not much more.

 

Almost any non-native compiler used with an IDE requires a few extra parameters

passed to the commands used. i've always had to set extra ones for HiTech and

MCC18 ...

Link to post
Share on other sites
Myself i do not see this as a bug ...

It should be documented in the install/setup instructions but not much more.

 

Almost any non-native compiler used with an IDE requires a few extra parameters

passed to the commands used. i've always had to set extra ones for HiTech and

MCC18 ...

 

I think of a bug as actions of a computer program that differs from the claimed behavior according to the program's documention. By this criterion, this is a bug. The fact that there is a work around is very nice; but the genertion of an incorrect option is just plain wrong.

Link to post
Share on other sites
Myself i do not see this as a bug ...

It should be documented in the install/setup instructions but not much more.

 

Almost any non-native compiler used with an IDE requires a few extra parameters

passed to the commands used. i've always had to set extra ones for HiTech and

MCC18 ...

 

I think of a bug as actions of a computer program that differs from the claimed behavior according to the program's documention. By this criterion, this is a bug. The fact that there is a work around is very nice; but the genertion of an incorrect option is just plain wrong.

 

 

But it is MPLAB itself that is generating the wrong flag, probably a legacy issue.

Link to post
Share on other sites

Fixed. Fix will be available in the next release. A workaround is to stop MPLAB if it is running, locate boostc.mtc file in MPLAB installation directory tree and change line 32 from:

 

Switch=-di

 

to:

 

Switch=-i

 

Do same change in boostc18.mtc, boostcpp.mtc, boostcpp18.mtc, boostbasic.mtc and boostbasic18.mtc

 

You also may need to re-generate MPLAB projects to pick up this change.

 

Regards,

Pavel

Link to post
Share on other sites

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...