Jump to content

Sourceboost Ide Installation

Recommended Posts



I´m trying to install SourceBoost IDE on my Vista x32 computer.


All goes well until the IDE starts then I get an error window, that the SourceBoost IDE MFC problem caused the application to shutdown.


I´m running Vista Business SWE x32.


What to do?





EDIT: I tried to run all the .exe files in the sourceboost file... No one works... I get the same MFC error window. My vista is up-to-date with updates from Microsoft. It´s sad that Sourceboost will not work on my Vista OS. I can get it to work on my XP machine, but I really would like it to work on mu Vista laptop as I´m developing a fuelpump controller and the test bench is in my workshop. =/

Edited by Fredrik
Link to post
Share on other sites
SourceBoost works well on my Vista machine. What is the name of the DLL that causes the problem?





There is no reference to any DLL in the error message... I´ve installed a "fresh" demo copy downloaded ver. 6.95.





Link to post
Share on other sites
  • 1 month later...

I got the same problem installing both versions (V6.95 and V5.9.7). Installer finishes its work and when application tries to start I got the message window "SourceBoost IDE MFC Application stopped working. " and a Close button. There´s no mention to any DLL. I run a Vista 32 Home Edition up-to-date.

Link to post
Share on other sites
I got the same problem installing both versions (V6.95 and V5.9.7). Installer finishes its work and when application tries to start I got the message window "SourceBoost IDE MFC Application stopped working. " and a Close button. There´s no mention to any DLL. I run a Vista 32 Home Edition up-to-date.

Although SB runs fine on my Vista Home Premium SP1 laptop, this reminds me of a problem with Corel Wordperfect x4, where you had to download a MFC lib file for VC 2005 before WP Lightning worked. This is a guess, but my interpretation is that the developer systems assumed the target environment will contain support libraries which are no longer present in Vista (or maybe they need to be updated)?

Link to post
Share on other sites

Today I downloaded SourceBoost for the first time. Completely new install.

It crashed when the application tried to launch for the first time. I am still unable to launch SourceBoost.


Edit: I just tried to run MPLab and it no longer runs.

I think I figured it out! I'm guessing that we both have Internet Explorer 8. Upon usingDependency walker I discovered that I was missing Internet Explorer DLL files like IEShims.dll. Whats more, I'm guessing that SourceBoost is incompatible with IE8

Edited by Craig
Link to post
Share on other sites

We will investigate though SourceBoost runs fine in our environment under Vista. Are you able to run just the compilers included into SourceBoost installation?


If anybody had this problem and managed to fix it please post here (or send a mail to support@sourceboost.com)


Here is a free tool that might help. It analyses application dependencies and shows them in a form of a tree. It can be downloaded from http://www.dependencywalker.com/. If you experience SourceBoost IDE crash under Vista please check the ide.exe file (that is the SourceBoost IDE main file that can be found in your SourceBoost installation directory) using this tool and post the results here.




Link to post
Share on other sites

ieshims.dll exists on my IE installation dir but couldn´t be found by ide.exe, so I copied it to same ide.exe dir. Crash problem persists but running depencywalker again, it finds ieshims.dll but it warns "at least one module has an unresolved import due to a missing export function in a delay-load dependent module".

According to dependencywalker, a Delay-load Dependency occurs when "Module A is delay-load linked with a LIB file for Module B at compile/link time, and Module A's source code actually calls one or more functions in Module B. Module B is a dynamic dependency and will only be loaded if Module A actually makes a call to Module B at run-time. Module B will be listed in Module A's delay-load import table." ..... any ideas????

Link to post
Share on other sites
  • 2 years later...

Hello Pavel,

It seems I was able to fix the Vista problem with the SourceBoost ide startup. Of course, this is a workaround, and I hope it will help to make future updates of the software work without it. I know how challenging it can be to fix a bug that you don't experience on your own system.


I'm glad I found a fix because I actually purchased the boostc full license before downloading the ide. I didn't think of testing it first. However,



The Problem:

SourceBoost ide (ide.exe) crashed immediately at startup every time, including immediately after installation. No error message detail were provided.

preg.exe also crashed immediately.

My system:

Windows Vista, with all updates. Dell XPS laptop M1530. MPLAB installed and working also.



The Fix:

1. Using the depency checker mentioned above http://www.dependencywalker.com/ to determine what dll's were missing. (in my case ieshims.dll)


2.You must disable the digital signing requirement for the sourceboost executables(procedure below)

Disabling "Data Execution Prevention" via control panel for each exe file (ide.exe, preg.exe, linker.exe, etc. in a list because actually the preg.exe and linker executables also terminated immediately with error).


So it seems that Vista's security features were directly deciding "priviledged instructions" required closing the program immediately. Not an anti-virus program, by windows itself.


Then, it works every time



I hope this helps with future product updates since it is running fine on your vista computer Pavel.




I used the dependency scanning program mentioned above and determined that the problem was a "second


chance privilidged instruction" error.


So, downloaded the dependency scanning program mentioned above, plus about 3 hours, and presto...




Here's the fix:

(Procedure for removing digital signature requirement for sourceboost executables)

go to - Control Panel, System, Advanced System Settings, Advanced Tab, Performance,

click Settings, Data Execution Prevention Tab, then click Add button to browse/select ide.exe, preg.exe and

the other needed executables in sourceboost - the result, IT WORKS!


After researching online, I found that Vista requires digital signing of all drivers in order to allow


them to register. So the RegisterService instruction was failing, then later in program startup, the


fatal error "priviledged instruction" for both ide.exe and preg.exe So, telling Vista to ignore the lack of digital signature essentially fixed the problem


for me.


So, if there is a way to include the digital signing of the drivers that would also fix this without


needing to change vista settings for the program.


I had initially installed the "ieshims.dll" into windows/system32/ and the sourceboost


directory and restarted computer before that which did not fix things by itself. From what I read that is probably also necessary for those


with the same vista problem I experienced.


It seems to be working fine - I will let you know if any future problems are encountered. I look forward to using the product. :(


Link to post
Share on other sites
  • 4 months later...
  • 3 months later...

I just updated to Windows 7 and thought I was screwed until I found this last post. Dang. It seems that the Source Boost installer should mention that this is required to get the product to work.


So I made the changes and now I can bring up SourceBoost IDE and registration code (which succeeded) but I can't compile a project. Even though it installed to the default location of "Program Files (x86)", the tool is looking for executables in "Program Files". I'll try uninstalling and forcing into Program Files and see if that fixes it.


I would think new users would be really crying about this or shopping elsewhere.


I figured out the build problem and it is due to the old project pointing at the old path. I was able to update the path in Settings --> Options --> Tools and my old project built. Shame on me. I still think the "Data Execution Prevention" issue needs to be addressed by the install program with a read me. I didn't have this problem with Vista, just Windows 7.

Edited by trossin
Link to post
Share on other sites



I find this a bit strange,


My Sourceboost installation did run well in my Vista Home Premium (32bit). Licence registration and regular use didn't show any problems.

I installed my second node on a Windows 7 Pro (64bit) laptop, also here everything went smoothly; instaled in Program Files (x86).

I interchange projects bettwen the two machines without any problem as long as I don't have explicit libs in the project files.

For instance when using the "NOVO RTOS" I need to explicitly include the "novoxxxxx.lib", and I have to reajust whem moving betwen computers. As long as it is only "system.h" nothing to be adjusted.



Best regards



Link to post
Share on other sites

We were able to reproduce the problem and are working on a solution. Current strategy is to add necessary settings during installation or warn user if computer settings need to be modified manually. Thanks to all for reporting.




Link to post
Share on other sites

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...