Jump to content

Boostc Preprocessor Bug In Mplab

Recommended Posts



I am using the boostC compiler in MPLAB.


Bug Description:


When creating a new project, I am including .c files and .h files from a library path which is outside the project directory.

At first attempt the project builds perfectly.


After I change the smallest settings in the dialogue located at Project>Build Options>Project>BoostLink Linker , the project suddenly fails to build.


For example, the only thing I change is to switch on verbose mode. I see after that that the build fails and apparently that the Preprocessor is looking for the files in the wrong path. The preprocessor tries to access the library source files via the project path which will make it fail, as they are not located there.


Is there any way I can tell the preprocessor where to look for the source files?


I have tried the additional command line option -I and specified the path to the library, but the preprocessor still throws the same error and the same wrong path to the project directory.


This error is reproducable.


Is this an error which is strictly related to MPLAB or is there a way to fix it with settings for boostc?


I am looking forward to some help!



Link to post
Share on other sites

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...