Jump to content

Mplab X Ver 1.1 Integration Success And Issues

Recommended Posts

I am running on MPLAB X ver 1.1 with SB ver 7.05.1 and ICD3.


To help others, I will list stumbling blocks I had and the 1 issue I need help with(see bottom)


Stumbling blocks overcome:

1)I installed MPLAB X after installing BoostC. If you want to do this, first read MplabX_Plugin.pdf in your SourceBoost root directory(C:\Program Files\Sourceboost). It tells you what you need to do.


2)To run NOVO RTOS, you need the -swsc linker option. To add linker options in MPLAB X, select File-Project Properties. Under categories, select "SourceBoost Linker for PIC...." Beside "Options categories", select the "Software Call Stack..." and check the box "Use Software Call Stack for all code"


3)When adding source or library files to your project in MPLAB X, you usually want to select "Auto" under "Store Path As" on the right side of the file chooser dialog.


The issue remaining(and my solution):

4) The library file libc.pic18.lib (for me using the PIC18F25K22) was not automatically included in the link like it is in the Sourceboost IDE. This results in lots of math routines not being found. The only way I got the project to link was to copy the file from C:\Program Files\Sourceboost\lib to my project directory and then add it to my library files in the project. I know this is not right, so if anyone has a better way to get this to work, let me know!


Thank you,


Link to post
Share on other sites

Hi Chuck



Like in previous versiosn of MPLAB, you have to add the "lib" file to the "library files" folder in yur project tree.

But MPLABX seems to have an issue with the pathnames, or at least with pathnames with spaces.

For testing purposes I seted up a special libs folder in a pathname without special caracters ( c:\SBLIBS\lib\...) and the "build" process went fine.



BTW, in a recent workshop on Microchip products, I understand that MPLABX is suffering from some issues with pathnames that seem to come from netbeans, but I don't have any precise details on that yet.




Best regrads



Edited by JorgeF
Link to post
Share on other sites


Thanks for the reply, I was not aware about the need to add the library file to the project.


I did try adding the library file to the project and yes, I did see the pathname problem in MPLAB X.

I agree that it probably has to do with the space in the pathname.

I have posted the path issue on the Microchip MPLAB X forum.



Link to post
Share on other sites

Hi Chuck,


Congratulations, sounds like you're doing a lot better than me.

Gave up on MPLAB 5 years ago, and have since (more or less happily) using BoostC standalone without MPLAB integration, I thought I'd like to be able to do in-circuit debugging using the PicKit3. So .. paid up and upgraded to SB 7.05.1 and downloaded MPLAB X 1.1, but it seems to me so far that MPLAB is just as plug-ugly as it was then, (but then I guess, so am I).


Pavel's carefully prepared PDF instructions for MPLABX integration (in the installation file set) worked fine right up to where the "toolchains" are added.

After nominating the SourceBoost folder as the "Base Directory" the types "SourceBoost C Compiler for PIC12 and PIC16" and "SourceBoost C Compiler for PIC18" are both listed as available in the "Type" dropdown box.

OK, so I selected the PIC12 & 16 type and clicked OK, but when I restart and try to add the PIC18 type, the message "Base directory is currently in use by another toolchain" appears and the "OK button is greyed out.

Trying it both ways, only one of the two types is allowed, unlike the screengrab in Pavel's PDF, which clearly shows both types resident in the same base directory.

I found I could only get both types included if I duplicated the contents of the SourceBoost folder into another folder of a different name and used a different base directory for each.

Don't think that's going to work!

Tried uninstall/reinstall etc .. no joy.

Apart from that, settling on one toolchain (PIC18) and loading a single port LED flasher of a few lines of working 18F452 BoostC code into the MPLABX editor, the thing raises errors saying it doesn't know anything about "tris" and "port". (red underline - unknown ...)

MPLABX doesn't seem particularly intuitive ... or is it just me?


Peter L

Link to post
Share on other sites

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...