Jump to content

Bogus File Can Not Be Saved Message

Recommended Posts

I'm using v7.05 but got the same results with v7.10

I have a file in my project that grew a bit and now when I make changes and go to build it I get a "File can not be saved" error.


The file is 39.2K and if I start SouceBoost, add a space and click the save icon I get the error.

reduced file down to 31.2K and it fails

reduced file down to 21.3 K and it works.


I created a brand new project and copied the files to a new directory and it fails the same way. I should mention that the smaller files of the project save just fine but once I try to save the large file, even the small files start failing.


It seems that the files do get saved, it is just this message pops up.


A work around is to split the file in two and add a bunch of function definitions but I wanted these functions to be hidden from other files.


Has anyone else seen this problem. I see it on Windows 8 and Windows 7.


I should mention that I removed all my plugin dll from the SourceBoost directory in case they were causing the problem and it did not solve the issue.

Link to post
Share on other sites

// FIXME: Add code to create new file


The above comment in my file caused the IDE to blow it. To make a long story short, I can not save a file with the word FIXME in the file. FIXM is fine but FIXME is verboten! So is lowercase fixme. int fixme; will also cause the bogus message. I'm pretty sure there is some code in the IDE looking for this string that needs to be removed.


--------More rambling---------------------------------


If I delele this line from my file, it can save it. If I put it back in, it can not.


Here is the context:


else if(SectorBuf[index]==0){ // Remaining indexes are free

Done = 1;


// FIXME: Add code to create new file




If I leave the line in, I get the error. If I do a cut, I can't. If I paste it back in, it fails.


Here is a much smaller case I was able to make fail. I attached the file. Just like before, cut the line with FIXME and you can save the file without the error message. Paste it back and the error message goes away.



CBLearn.c: A file to play around with the compiler



// FIXME: Add code to create new file

#include <system.h>

void Poo(unsigned long Sec)


unsigned long Value;


Value = Sec;


#define OFFSET 3

char SectorBuf[512];

void main()


unsigned long Sector=0x12345678;

unsigned char Loop;

unsigned int Index;


unsigned long lw;

unsigned char b[4];

} It;


Sector = *(unsigned long *)&SectorBuf[index];





Edited by trossin
Link to post
Share on other sites

I could not reproduce the problem. Here is what I did:


1. add file to an existing project

2. open it inside SourceBoost IDE

3. add some text

4. save

5. check if the changes appear in the file using an outside editor (ok)

6. do more changes in the file from inside SourceBoost IDE

7. close the file (this will make IDE ask if the changes need to be saved, answer yes)

8. check if the changes appear in the file using an outside editor (ok)


Any suggestions how to reproduce the problem?





Link to post
Share on other sites



As a quick test I simply added the text "// FIXME:" as described by trossin to one of my project files. I can concur that this caused a save file error when trying to compile. This was with BoostC IDE v7.10 on Vista. Interestingly, I couldn't get it to fail when using BoostC IDE on WINXP or from within MPLAB V8.87 on Vista so I am guessing it is a platform related problem. It doesn't seem to be related to the number of files or their size in a project.


Very strange but the obvious fix is to not use the text FIXME!


Hope that helps



Link to post
Share on other sites



Same resuts here.

Created a new empty project with only one source file with the following code:


void main(void)

When saving the file or exiting the IDE I got the error dialog saying the file cannot be saved.

But the file is in fact saved as verified with Notepad++.


The problem only goes away when the word "FIXME" is removed or replaced. For example "FIX ME" solves the issue.

If the file is in the project but is not open in the IDE editor then no problem at all.


The issue could not be replicated with MPLAB 8.86 IDE what was to be expected as it seems to be an IDE/Editor issue and not a Compiler one.


A quick and dirty workaround I found is to close the file "discarding any changes" after the first save error.

As the file was in fact saved we can say "ok" to the save error and then close the file discarding changes.



Context details:

Sourceboost V7.10

Windows 7 Pro 64 bits

User account is member of Domain Admins and local administrator with UAC disabled.



Best regards


Edited by JorgeF
Link to post
Share on other sites

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...