Jump to content

License Registration not working

Recommended Posts


I have installed Sourceboost 7.42 and ran preg.exe as administrator, entered my name and license key, clicked OK and it says:



boostc_pic16.exe: success
boostc_pic18.exe: success


However when I click the build button in the IDE the linker always complains:



License restricted by the following files:
Recompile the code with a less restrictive compiler license!
License exceeded by RAM: 880 bytes
License exceeded by ROM: 2448 bytes

You have reached the limit of the Lite License (Unregistered)
PIC18 max code size:8192 bytes, max RAM banks:2, Non commercial use only
You can upgrade your license. Please visit: http://www.sourceboost.com


What can be wrong?

OS is Windows 10 64bit

Link to post
Share on other sites



Assuming those object files are part of your code, the linker might be trying to reuse them without a new compilation.

Just force a full recompilation of all the source code.



Best regards



Link to post
Share on other sites

Already tried that yesterday through build->clean and didn't solve the problem but today I deleted the files from the "Release" folder manually, then I did a recompile and it worked!

Some source code files are in a sub directory in my project dir and it seems the IDE doesn't remove the .obj files for the .c that are in the subdirectory when you do build -> clean.

Thanks for the help


Link to post
Share on other sites

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...